香港小果奶奶心论坛,香港小喜印刷图库,纵横天下高手论坛,香港小鱼儿手机开奖——祥云县热点要闻

您现在的位置:主页 > 教育新闻 >

教育新闻

解决CentOS中gcc版本过低的问题

发布日期:2021-11-23 16:55   来源:未知   阅读:

  C++11,(即ISO/IEC 14882:2011),是目前的C++编程语言的最新正式标准。它取代了第二版标准(第一版公开于1998年,第二版于2003年更新,分别通称C++98以及C++03,两者差异很小)。新的标准包含核心语言的新机能,而且扩展C++标准程序库。C++11新标准由C++标准委员会于2011年8月12日公布,并于2011年9月出版。此次标准为C++98发布后13年来第一次重大修正。

  因此,如果我们代码里面需要用到c++标准的,就必须将gcc升级到gcc4.7以上。

  如果直接升级了系统自带的gcc,有可能导致系统自带的程序出现不兼容的情况,导致系统崩溃。因此,升级的时候必须考虑自定义目录,不能覆盖系统的路径下的gcc。

  10、有些代码里面还会用到cc这个命令来调用gcc ,而我们自己编译的目录下没有cc这个执行程序,可以做个软链接就可以了。

  如果我们升级的gcc导致有些程序无法执行需要回退,可以直接删除环境变量即可。

友情链接:

Power by DedeCms